Меню Рубрики

Amdgpu pro linux mint

Amdgpu pro linux mint

Никто не смог предложить внятного решения. У меня нет времени разбираться. Компьютер используется для работы.

Купил и установил видеокарту Radeon rx570. Установил драйвера с официального сайта. Итог: cinamon не стартует. Точнее стартует в аварийном режиме и просит перезапуститься. Немного погуглив, добавил в строку загрузки:

radeon.cik_support=0 amdgpu.cik_support=1 radeon.si_support=0 amdgpu.si_support=1

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] (rev ef) (prog-if 00 [VGA controller])

Subsystem: Sapphire Technology Limited Nitro+ Radeon RX 570/580
Flags: bus master, fast devsel, latency 0, IRQ 7, NUMA node 0
Memory at c0000000 (64-bit, prefetchable) [size\=256M]
Memory at dfe00000 (64-bit, prefetchable) [size\=2M]
I/O ports at ce00 [size\=256]
Memory at fd580000 (32-bit, non-prefetchable) [size\=256K]
[virtual] Expansion ROM at 000c0000 [disabled] [size\=128K]
Capabilities:
Kernel modules: amdgpu

Почему так происходит? Есть идеи?

Linux Mint 19 и amdgpu

Linux Mint 19 и amdgpu

Linux Mint 19 и amdgpu

Linux Mint 19 и amdgpu

Очевидные советы:
1. Если уж поиск решения прямо голову разбивает, то можно попробовать установить драйвер от Mesa3D (как минимум у меня с ним проблем нету уже месяцев 8-9 после его первой установки, но amgpu драйвер я даже не использовал, хотя люди и на него не жалуются. Устанавливал через репы убунты, а не через офф сайт Mesa).
2. Если личные данные сохранены отдельно (или есть лишний жесткий диск), то можете попробовать переустановить (установить на другой жесткий диск) систему и заново установить драйвер, чтобы исключить фактор того, что вы поставили драйвер на какие-то старые файлы/драйвера, которые конфликтуют между собой. Если ошибка повторится, то значит, что вы как-то не так ставите драйвер или не ту версию.
3. Дождаться экспертов по чтению логов, которые вас за ручку по ним будут водить.

Так же стоит отметить, что последняя версия драйвера amdgpu написана для Ubuntu 18.04.2, не знаю, совместима ли она с Linux Mint 19 или для LM нужен драйвер старее. Без понятия, можно ли вообще случайно (или если очень захотеть) эту версию поставить в условной Ubuntu 18.04, если он написан для Ubuntu 18.04.2, и будет ли он адекватно функционировать при этом.

Linux Mint 19 и amdgpu

1. Mesa – это дефолтный видео драйвер для Ubuntu? Я бы хотел удалить весь возможный мусор, который скопился после экспериментов с дровами. Как это сделать?

Допустим, я запущу amdgpu-uninstall и amdgpu-pro-uninstall (устанавливал обе версии). Это удалить amdgpu. Как найти и вычистить остальное? Возможно у меня даже экспериментальный репозиторий mesa подключен. Как вернуть всё к дефолтному виду?

Источник

Amdgpu pro linux mint

Установка видеодарайвера AMD Radeon AMDGPU-Pro Driver Version 16.40 на Linux Mint 18.1

Установка видеодарайвера AMD Radeon AMDGPU-Pro Driver Version 16.40 на Linux Mint 18.1

Установка видеодарайвера AMD Radeon AMDGPU-Pro Driver Version 16.40 на Linux Mint 18.1

Установка видеодарайвера AMD Radeon AMDGPU-Pro Driver Version 16.40 на Linux Mint 18.1

/etc/lsb-release такого нет
есть /etc/os-release (ссылка на этот файл есть в amdgpu-pro-install)
там заменил
NAME=”Ubuntu”
VERSION=”16.04″
ID=Ubuntu
ID_LIKE=ubuntu
PRETTY_NAME=”Ubuntu”
VERSION_ID=”16.04″
HOME_URL=” http://www.linuxmint.com/ ”
SUPPORT_URL=” http://forums.linuxmint.com/ ”
BUG_REPORT_URL=” http://bugs.launchpad.net/linuxmint/ ”
VERSION_CODENAME=”Ubuntu 16.04 LTS”
UBUNTU_CODENAME=xenial

не помогло (
Unsupported OS

Установка видеодарайвера AMD Radeon AMDGPU-Pro Driver Version 16.40 на Linux Mint 18.1

надо писать с маленькой буквы u

Драйвер вроде установился.
На втором мониторе (телевизоре) пропало максимальное разрешение 🙁

Установка видеодарайвера AMD Radeon AMDGPU-Pro Driver Version 16.40 на Linux Mint 18.1

Установка видеодарайвера AMD Radeon AMDGPU-Pro Driver Version 16.40 на Linux Mint 18.1

надо писать с маленькой буквы u

Драйвер вроде установился.
На втором мониторе (телевизоре) пропало максимальное разрешение 🙁

Установка видеодарайвера AMD Radeon AMDGPU-Pro Driver Version 16.40 на Linux Mint 18.1

У меня доступна только 4.8.0 (Linux Mind)
Не работает аппаратное ускорение при воспроизведение видео (загрузка процессора около 50%)
Что делать?
Padoka Stable Mesа будет работать на Kernel: 4.4.0-53-generic x86_64 (64 bit) ?

Читайте также:  Local server on linux

PS Оля, спасибо большое за помощь, но вопросы остались без ответа, по этому ставил драйвера для видокарточки

Установка видеодарайвера AMD Radeon AMDGPU-Pro Driver Version 16.40 на Linux Mint 18.1

Установка видеодарайвера AMD Radeon AMDGPU-Pro Driver Version 16.40 на Linux Mint 18.1

себя добавил, перегрузился. Вроде всё работает, но разрешение на телевизоре низкое и большая частота (60)
через “параметры системы” установить можно мин (50 герц)
На месса частота была 30 на разрешение HD

как установить Padoka Stable Mesa? PPA это то?

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt-get update

Установка видеодарайвера AMD Radeon AMDGPU-Pro Driver Version 16.40 на Linux Mint 18.1

Установка видеодарайвера AMD Radeon AMDGPU-Pro Driver Version 16.40 на Linux Mint 18.1

serg123 писал(а): себя добавил, перегрузился. Вроде всё работает, но разрешение на телевизоре низкое и большая частота (60)
через “параметры системы” установить можно мин (50 герц)
На месса частота была 30 на разрешение HD

как установить Padoka Stable Mesa? PPA это то?

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt-get update

Установка видеодарайвера AMD Radeon AMDGPU-Pro Driver Version 16.40 на Linux Mint 18.1

Как то не правильно установил месу и получил черный экран (

Как откатываться, что бы не переустанавливать систему?

Установка видеодарайвера AMD Radeon AMDGPU-Pro Driver Version 16.40 на Linux Mint 18.1

Установка видеодарайвера AMD Radeon AMDGPU-Pro Driver Version 16.40 на Linux Mint 18.1

нет, не удалял 🙁
sudo aticonfig –uninstall ?

4.4 версия LTE. Хотел её оставить.

Нужно программу установить для отката?

Установка видеодарайвера AMD Radeon AMDGPU-Pro Driver Version 16.40 на Linux Mint 18.1

команда удаления amdgpu-pro-uninstall
ты что ставил, падока или оибаф? тебе лучше закоментить сейчас новый драйвер , загрузится, потом обновить ядро и поставить падоку или оибаф

Источник

Linux Mint Forums

Welcome to the Linux Mint forums!

How do I install AMDGPU-Pro on Mint 19?

How do I install AMDGPU-Pro on Mint 19?

Post by Dukenukemx » Mon Jul 02, 2018 1:01 am

Re: How do I install AMDGPU-Pro on Mint 19?

Post by catweazel » Mon Jul 02, 2018 3:01 am

Follow the clear, written instructions.

You will note that there are no instructions for Ubuntu 18.04. Since AMD offer a driver for Ubuntu 17.04, presumably you need to download the correct driver for Ubuntu 18.04, which Mint is based on. Once you find that, you can follow the instructions as linked to above, but skip the sudo apt dist-upgrade command. However there may not be a driver for 18.04 yet.

Re: How do I install AMDGPU-Pro on Mint 19?

Post by Dukenukemx » Mon Jul 02, 2018 10:43 am

They’ve had drivers for Ubuntu 18.04 for a while now, they’re called AMDGPU-PRO 18.20. Yea the name is confusing. Also I am following the instructions. It says to run ‘./amdgpu-pro-install –y’ and that’s what I did, and got that output. You didn’t even read my post @catweazel .

Re: How do I install AMDGPU-Pro on Mint 19?

Post by roblm » Mon Jul 02, 2018 12:12 pm

Re: How do I install AMDGPU-Pro on Mint 19?

Post by Dukenukemx » Mon Jul 02, 2018 1:10 pm

Re: How do I install AMDGPU-Pro on Mint 19?

Post by roblm » Mon Jul 02, 2018 1:29 pm

Use this command, removing the -y option. That’s the only way I could install that driver: ./amdgpu-pro-install

Or this one, to also install the OpenCL files: ./amdgpu-pro-install –opencl=legacy

Without the -y option, the installation will stop at one point and you will need to answer Yes.

Re: How do I install AMDGPU-Pro on Mint 19?

Post by Dukenukemx » Mon Jul 02, 2018 6:02 pm

Re: How do I install AMDGPU-Pro on Mint 19?

Post by Dukenukemx » Mon Jul 02, 2018 6:29 pm

Re: How do I install AMDGPU-Pro on Mint 19?

Post by sampctech » Tue Aug 21, 2018 3:08 pm

Читайте также:  Linux как удалить vmware workstation

What do I do to install it?

Here is what I currently have for my system:

Re: How do I install AMDGPU-Pro on Mint 19?

Post by roblm » Wed Aug 22, 2018 2:12 pm

If you read all the posts in this topic, then you should know that the -y option should be left off the installation command.

Your inxi output lists AMD Ryzen 3 2200G with Radeon Vega Graphics, which is an APU.

User Citizen229, in his topic says the AMDGPU-Pro driver can’t be installed on mobile GPUs as well as APUs:
viewtopic.php?f=59&t=248059

I’ve been looking for a statement by AMD to verify that but still haven’t found one, so you will be testing an installation that may fail, but first change the word linuxmint back to ubuntu in the amdgpu-pro-install script. I’ll explain why later. I recommend a new installation. Otherwise, there will probably be an error message about unmet dependencies when you attempt a second installation. Use this command to try to fix that: sudo apt install –fix-broken

With the release of the Radeon Software for Linux 18.30 package, AMD has added another obstacle to the installation for Mint users who want to install the AMDGPU-Pro driver. With previous versions, the amdgpu-pro-install script was edited by changing the word ubuntu to linuxmint. That won’t work with the newest version. After the installation, if you view the installer log in the Terminal window, you will probably see these 3 lines at the end:

This script will run before the amdgpu-core package is installed. It checks in the system’s /etc/os-release file for a VERSION_ID=”18.04″ line, which is the latest version of Ubuntu. If that is not found, then the amdgpu-core package will not be installed, the error message will be seen in the installer log and the installation will fail.

The solution I found is to edit the /etc/os-release file. Use this command to open it: xed admin:///etc/os-release

Change the word linuxmint to ubuntu in line 3 and change the number 19 to 18.04 in line 6. After the installation, you can change these back. The amdgpu-pro-install script does not have to be edited.

Proceed with the installation by right clicking on the downloaded amdgpu-pro-18.30-633530.tar.xz package and selecting Extract Here. Open the amdgpu-pro18.30-633530 folder. Right click in the empty space and select Open in Terminal. Use the command ./amdgpu-pro-install

If you also want to install the OpenCL component, then use this command for Vega10 and newer cards:
./amdgpu-pro-install –opencl=pal

Or this command for Pre Vega10 cards: ./amdgpu-pro-install –opencl=legacy

Also, AMD says both pal and legacy can be installed, which is useful for users who are unsure which option should be selected: ./amdgpu-pro-install –opencl=pal,legacy

To uninstall the driver: amdgpu-pro-uninstall

How to check the AMDGPU-Pro installation :

Use this command: grep hybrid /var/log/Xorg.0.log . Check for these two lines, referring to the AMDGPU hybrid driver. Your version number may be different:

UPDATE : Mint 19 Cinnamon installation. These instructions were tested and also work on both Radeon Software for Linux 18.40 and 18.50.

UPDATE : Mint 19.1 Cinnamon installation. 4.15.0-20 kernel. Radeon Software for Linux 18.50 ( amdgpu-pro-18.50-708488-ubuntu-18.04.tar.xz) installed successfully.

UPDATE : Tested 4.15.0-46 and 4.15.0-47 kernels with amdgpu-pro-18.50-756341-ubuntu-18.04.tar.xz package. No problems.

Tested 4.18.0-17 kernel. Installation failed. This message seen:

After rebooting, you will end up in the virtual console tty1, unable to get to the desktop. To correct that problem, this command should be used to re-install those packages, right after Radeon Software for Linux 19.10 is uninstalled, before rebooting. It can also be used in tty1:
apt install xserver-xorg xserver-xorg-video-all

EDITED 5-24-19: the 5.0.0-15 kernel in the Update Manager is not supported by Radeon Software for Linux 19.10. This message will be seen in the installation log:

Читайте также:  Эмулятор андроид для linux mint

UPDATE 6-19-19 : The Radeon Software for LInux 19.20 for Ubuntu 18.04.2 installs the same as 19.10. No files need to be edited, but the same uninstallation problem exists. It also works with the 4.18 and 5.0.0-15, 5.0.0-16 and 5.0.0-17 kernels.
https://www.amd.com/en/support/kb/relea . 20-unified

EDITED 7-7-19 : This package is not compatible with the 4.15 kernel.

The Xorg.0.log file does not show these lines when the 4.18 or 5.0 kernel is installed, as previous Radeon Software versions did, to verify the installation:

Update 8-16-19 : Tested Radeon Software for Linux version 19.30 for Ubuntu 18.04.3 on Mint 19.2.
https://www.amd.com/en/support/kb/relea . fied-linux

Installation is similar to the previous version; no files need to be edited, but the uninstallation problem persists, which started with Radeon Software for Linux 19.10. This driver package is compatible with the 4.15, 4.18 and 5.0 kernels. Tested were the 4.15.0-54, 4.15.0-58, 4.18.0-25 and 5.0.0-25 kernels.

Update 11-10-19 : Tested the 5.3.0-19 kernel with Radeon Software for Linux version 19.30 for Ubuntu 18.04.3 in the package amdgpu-pro-19.30-855429-ubuntu-18.04.tar.xz. The driver failed to install.

AMD just released on 11-8-19 a revision of Radeon Software for Linux version 19.30 in the package amdgpu-pro-19.30-934563, which has driver support for the new Radeon RX 5500 series. This driver also does not have support for the 5.3 kernel.
https://www.amd.com/en/support/kb/relea . 30-unified

EDITED 12-25-19: With the release of Mint 19.3, Radeon Software for Linux is finally working correctly. Version 19.30 installed without any editing of a configuraton file and the uninstallation problem that was introduced in version 19.10 has been eliminated.

Update 1-6-2000 : Using Mint 19.3 Cinnamon and the 5.0.0-32 kernel, tested Radeon Software for Linux version 19.50 for Ubuntu 18.04.3 in the package amdgpu-pro-19.50-967956-ubuntu-18.04.tar.xz.
https://www.amd.com/en/support/kb/relea . fied-linux

This package has problems. The AMDGPU driver installation with the All-Open component ( amdgpu-install), will install but the installation will be about 4 minutes longer. When the step Building initial module for 5.0.0-32-generic is reached, there will be about 6 minutes needed. Usually this step takes about 2 minutes for building the 4 AMD kernel modules.
The installation with the Pro component ( amdgpu-pro-install) will fail with these lines in the installation log:

I installed build-essential and then the amdgpu-pro driver installation appeared to be successful, except for the extra 4 minutes needed. However, upon rebooting, there was a black screen, so the driver had to be removed in tty1.
Same result using the 4.15.0-72 kernel. The 5.3.0-xx kernel is still not supported.

EDITED:
Radeon Software for Linux 19.50 is supposed to support Ubuntu 18.04.3, so I tested that OS using the 5.0 kernel and got identical results.

Update 7-21-2020 : I suspected my old Radeon R7 240 video card was the cause of not being able to install the AMDGPU-Pro driver from any package since Radeon Software for Linux version 19.30, although AMD said the card was still supported up to Radeon Software for Linux version 20.10. I think the card lost support right after version 19.30 but AMD did not remove it from their supported list of products right away. The most recent version, Radeon Software for Linux version 20.20 for Ubuntu 20.04, does not list that card anymore on the supported list.
I recently purchased a newer inexpensive AMD card; the Radeon RX 560. I tested all the Radeon Software versions that did not work with the previous card and here are the results:

Mint 19.3 using the 5.0.0-32 kernel:
Radeon Software for Linux version 19.50 for Ubuntu 18.04.3 fails, but after installing build-essential, it works.

Mint 19.3 using the 5.3.0-62 kernel:
Radeon Software for Linux version 20.10 for Ubuntu 18.04.4 HWE works, without installing build-essential.
Radeon Software for Linux version 20.20 for Ubuntu 20.04 fails.

Источник

Популярные записи

Adblock
detector