Меню Рубрики

Cisco packet tracer linux не запускается

Не удается запустить Cisco Packet Tracer

Здравствуйте. Уже где-то неделю мучаюсь с уставкой пакет трейсера. ОС: Debian testing, amd64. Сначала пробовал поставить с убунтовского deb-пакета. Лог установки:

При запуске выдает:

Неужели никто не знает? 🙁

обычно говорит о том, что либо исполняемый файл не соответствует архитектуре или OS (file /usr/local/PacketTracer6/bin/PacketTracer6), либо использует динамический линковщик другой версии.

Например под x86-64 запустить 32битное приложение без glibc-multilib нельзя.

xdg-desktop-menu: команда не найдена

Русским языком тебе говорит.

Это не важно.Это просто говорит о том, что не удалось создать запись в xdg-menu, которым я,собственно, не пользуюсь (awesome wm).

Не нашел в репозиториях такого пакета. Поддержка multiarch стоит, если что. Вывод file:

Я не знаю как такое сделать человеческим путем, знаю только сложный способ

на i386 (x86) libc.so.5

На стековерфлов предлогают конструкцию «readelf -a | grep interpreter:»

Здраствуйте, долго не отвечал, времени все не было 🙁

Источник

Cisco Packet Tracer 7.1 не запускается

Я установил Packet Tracer 7.1, используя командные строки. Он установлен отлично, но когда я набираю packettracer, он просто говорит

starting packettracer 7.1

, но не работает. Я пробовал все решения, которые я нашел в Интернете, но они не работали.

11 ответов

Если вы проверяете библиотеки, требуемые с помощью этой команды:

cd /opt/pt/bin ldd Packettracer7

вы увидите все библиотеки, в которых есть недостающие . Чтобы решить эту проблему, просто скопируйте библиотека отсутствует:

sudo cp /opt/pt/lib/libname /usr/lib/x86_64-linux-gnu

И ta da . Проблема решена

Перейдите в каталог, где установлен PacketTracer (это значение по умолчанию):

, затем запустите PacketTracer7

Теперь, если он показывает список отсутствующих библиотек «libqt5xxx», пожалуйста, установите их все.

sudo apt install libqt5xxx*

Помните, просто напишите все, что стоит за первым. и поместить * в конец имени пакета.

В моем случае это был пакет с именем «libQt5Script.so.5», поэтому я сделал это:

sudo apt-get install libQt5Script*

После этого работа PacketTracer7

должна теперь работать.

Я смог запустить Cisco Packet Tracer 7.1 на Ubuntu 16.04, выполнив следующие действия:

1-Cisco Packet Tracer 7.1 требует, чтобы более старая версия пакета не присутствовала на Ubuntu 16.04, поэтому вам нужно получить его, набрав

2- Чтобы установить пакет, который вы только что загрузили, введите

sudo dpkg -i libicu52_52.1-3ubuntu0.7_amd64.deb

3- Проверьте правильную установку с помощью этих команд

sudo updatedb; locate libicui18n

Проверьте, установлены ли следующие пакеты:

/usr/lib/x86_64-linux-gnu/libicui18n.so.52 /usr/lib/x86_64-linux-gnu/libicui18n.so.52.1 [ ! d5]

Это пакеты, необходимые для работы Cisco Packet Tracer.

Теперь вы можете ввести packettracer на терминал, и программа должна запуститься.

Открытый идентификатор типа packagetracer, убедитесь, что вы используете два t, packagetracer not packetracer, не чувствительны к регистру, не нужно менять каталог, я запускаю версию 7.1.1 на ubuntu 14.04, не нужно вводить packettracer7 или packettracer7.1.1 только пакетный трафик.

Читайте также:  Grep linux примеры регулярные выражения

Программа My Packettracer в / opt / pt, где она установлена, называется packettracer.

i зафиксировал это

, затем эту командную строку

sudo dpkg -i libicu52_52.1-8+deb8u6_amd64.deb

Известна проблема между трассировщиком пакетов 7.1 и Ubuntu 16.04, которая блокирует запуск трассировщика пакетов. Трассируемому пакету нужна библиотека libicui18n.so.52, которая была обновлена ​​libicui18n.so.55 в Ubuntu 16.04. Чтобы решить эту проблему, нам необходимо загрузить и установить более старую версию этой библиотеки. Старая версия этой библиотеки доступна в пакете Debian по адресу: –

Выполнить следующие команды для загрузки и установки этого пакета

wget http://security.ubuntu.com/ubuntu/pool/main/i/icu/libicu52_52.1-3ubuntu0.7_amd64.deb sudo dpkg –i libicu52_52.1-3ubuntu0.7_amd64.deb sudo updatedb

После установки пакета выполните следующую команду для обновления пути к библиотеке

Если вы проверяете библиотеки, требуемые с помощью этой команды:

cd /opt/pt/bin ldd Packettracer7

вы увидите все библиотеки, в которых есть недостающие . Чтобы решить эту проблему, просто скопируйте библиотека отсутствует:

sudo cp /opt/pt/lib/libname /usr/lib/x86_64-linux-gnu

И ta da . Проблема решена

Перейдите в каталог, где установлен PacketTracer (это значение по умолчанию):

, затем запустите PacketTracer7

Теперь, если он показывает список отсутствующих библиотек «libqt5xxx», пожалуйста, установите их все.

sudo apt install libqt5xxx*

Помните, просто напишите все, что стоит за первым. и поместить * в конец имени пакета.

Источник

Курс по основам компьютерных сетей на базе оборудования Cisco. Этот курс поможет вам подготовиться к экзаменам CCENT/CCNA, так как за его основу взят курс Cisco ICND1.

1.5 Установка Cisco Packet Tracer 7.1 на дистрибутив Linux Ubuntu 16.04

Привет, посетитель сайта ZametkiNaPolyah.ru! Продолжаем изучать основы работы компьютерных сетей, напомню, что эти записи основаны на программе Cisco ICND1 и помогут вам подготовиться к экзаменам CCENT/CCNA. Ранее мы рассмотрели процесс установки приложения Cisco Packet Tracer на Windows, теперь давайте сделаем то же самое, но теперь будем устанавливать Cisco Packet Tracer 7.1 на Ubuntu 16.04. Чтобы не футболить вас обратно к первой публикации, здесь я повторюсь и повторно дам информацию о том, где скачать и как зарегистрировать это приложение.

При установке Packet Tracer на Ubuntu 16.04 у вас могут возникнуть трудности с запуском программы, здесь я опишу одно решение, которое помогло мне, если оно вам не поможет, то воспользуйтесь англоязычным Гуглом, уверен, там вы найдете решение своей проблемы очень быстро.

Перед началом я хотел бы вам напомнить, что ознакомиться с опубликованными материалами первой части нашего курса можно по ссылке: «Основы взаимодействия в компьютерных сетях».

1.5.1 Где скачать официальную версию программы Cisco Packet Tracer?

Если вы задались вопросом где скачать официальную и последнюю версию Cisco Packet Tracer, а затем ее решили установить на свой Linux дистрибутив Ubuntu 16.04, то наверняка вам не нужно рассказывать о возможностях данного продукта, но если все-таки нужно, то рекомендую обратится к предыдущей записи, в которой мы установили Cisco Packet Tracer на Windows 10.

Читайте также:  Пакеты для linux mint

Здесь мы разберемся с самым правильным способом получения официальной и самой последней копии приложения Cisco Packet Tracer без всяких ограничений и при этом бесплатно. Конечно же, скачивать Packet Tracer лучше всего с официального сайта, вот ссылка.

Но, Cisco просто так нам этого сделать не даст, для доступа к приложению нам нужно сперва зарегистрироваться на сайте академии Cisco, а затем уже скачивать, поэтому жмем на синюю кнопку, которая показана Рисунке 1.5.1.

Рисунок 1.5.1 Ссылка на скачивание Packet Tracer

И переходим к созданию аккаунта на сайте академии Cisco. Конечно, Packet Tracer можно скачать с какого-нибудь файлообменника и не думать о регистрации, но тогда у вас будут каждый раз определенные сложности при запуске приложения: при каждом запуске придется ждать 15 секунд, прежде чем можно будет начать работать, так как в данный момент нужно регистрировать приложение.

1.5.2 Создаем аккаунт на сайте академии Cisco

После того, как мы нажмем на кнопку регистрации, нас перенесет на страницу, в правой части которой есть поле для ввода адреса электронной почты, вводим смело свой адрес и жмем на кнопку Submit. Примечание: адрес на Рисунке 1.5.2 демонстрационный и в дальнейшем я его использовать не буду, просьба не пытаться связаться со мной при помощи этой почты.

Рисунок 1.5.2 Вводим e-mail для регистрации на сайте академии Cisco

Как только вы ввели e-mail, вам предложат заполнить простую личную анкету, все поля там простые и очевидные и никаких пояснений не требуют. Разве что стоит упомянуть, что поле дата рождения должна заполняться в таком формате, как показано на Рисунке 1.5.4, а пароль обязательно должен состоять не менее, чем из восьми символов, в пароле должна быть как минимум одна большая буква и цифра. Первая часть анкеты, заполненная мной на рисунке 1.5.3.

Рисунок 1.5.3 Заполняем анкету на сайте академии Cisco

Обратите внимание: чтобы ширина скриншота была приемлемой для публикации, я открыл браузер в половину ширины экрана, а это означает, что сама анкета у вас может выглядеть по-другому, вторая часть анкеты показана на Рисунке 1.5.4.

Рисунок 1.5.4 Создаем учетную запись

Ввели данные и нажимаем синюю кнопку с надписью: «Создать учетную запись». Сайт обработает ваши данные, перенаправит вас в личный кабинет в академии и пришлет на указанный ранее почтовый ящик письмо с ссылкой для подтверждения, не забудьте подтвердить свой аккаунт по ссылке, которая будет в этом письме. После подтверждения учетной записи переходите к скачиванию. На Рисунке 1.5.5 показан фрагмент меню, которое расположено в правом верхнем углу личного кабинета (ссылка на загрузку Packet Tracer подсвечена).

Читайте также:  Длинные имена файлов в linux

Рисунок 1.5.5 Ссылка на скачивание Cisco Packet Tracer

Нас перенесет на страницу загрузки Cisco Packet Tracer, здесь можно найти версию приложения для различных операционных систем, обратите внимание: на момент написания этого текста актуальной версией является Cisco Packet Tracer 7.1. Как видно из Рисунка 1.5.6, на странице загрузки нет упоминания Cisco Packet Tracer для Ubuntu 16.04, поэтому проблемы с этой версией дистрибутива возникают всегда.

Рисунок 1.5.6 Страница загрузки Cisco Packet Tracer

Чтобы начать скачивание, нажмите на нижнюю зеленую кнопку, именно за ней скрывается ссылка на скачивание Cisco Packet Tracer для Linux. Также обратите внимание: считав QR-код с экрана, вы сможете загрузить на свой смартфон приложение, которое поможет вам изучить Cisco Packet Tracer, рекомендую ознакомиться, аналогичная возможность есть и на сайте академии.
Хочу обратить ваше внимание на то, что Cisco Packet Tracer подойдет для изучения и прохождения курсов Cisco, помогающих получить сертификат CCNA разных направлений, это приложение имеет функционал, который частично востребован для изучения материала, необходимого для получения сертификата CCNP, но этого будет недостаточно. Дело в том, что Cisco Packet Tracer эмулирует функционал реальных устройств Cisco (но не сами коммутаторы/маршрутизаторы, как это сделано в GNS3, например, который работает по принципу VirtualBox, только в VirtualBox мы устанавливаем гостевую операционную систему ПК, а в GNS3 мы устанавливаем операционную систему реального сетевого устройства), но далеко не весь функционал. Работая с коммутаторами и маршрутизаторами Cisco через Packet Tracer, поначалу вы не увидите отличий от реальных устройств, но в дальнейшем вы столкнетесь с ограничением функционала. Дело все в том, что вкусная часть сложных и интересных функций реальных устройств просто не реализовано в Packet Tracer.

1.5.3 Как установить Cisco Packet Tracer на Ubuntu 16.04

Давайте теперь перейдем к установке Cisco Packet Tracer на Ubuntu 16.04. Этот процесс довольно прост и быстр. Первое, что нужно сделать: открыть, например, в Nautilus каталог, в который вы скачали архив с программой и затем распаковать этот архив.

На Рисунке 1.5.7 показан процесс распаковки архива, из контекстного меню, появляющегося по нажатию правой кнопки мыши по иконки архива, я выбрал пункт «Извлечь сюда», так как пользуюсь виртуальной машиной и стандартный каталог загрузок меня полностью устраивает, вы же можете распаковывать архив туда, куда вам удобно.

Рисунок 1.5.7 Распаковка архива с Cisco Packet Tracer

Как только архив будет извлечён, у вас появится каталог с название, похожим на это: PacketTracer71_64bit_linux. Теперь открываем эмулятор терминала, пользуемся горячими клавишами Ctrl+Alt+T. В терминале действуем по алгоритму, описанному ниже.

1. Переходим в каталог, который мы только что распаковали (команда cd):

Источник

Adblock
detector